Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Bug #1069 (closed)

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

AttributeError: 'NoneType' object has no attribute 'name'

Reported by: agilouser Owned by:
Milestone: Agilo 0.7.0 (Phoenix) - Sprint 4 Sprint: n.a.
Impact: n.a. Complexity: n.a.
Total Remaining Time: n.a.

Description

To reproduce, I click on dashboard or normal sprint view.

Auto generated report

While doing a GET operation on /oldbacklog/Sprint Backlog/Piloto 1, Trac issued an internal error.

Request parameters:

{'name': u'Sprint Backlog', 'scope': u'Piloto 1'}

User Agent was: Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7

System information

System Information ¶
Trac 	0.11.6
Python 	2.6.4rc2 (r264rc2:75497, Oct 20 2009, 03:10:19)
[GCC 4.4.1]
setuptools 	0.6c9
SQLite 	3.6.16
pysqlite 	2.4.1
Genshi 	0.5.1
mod_python 	3.3.1
Agilo 	1.2.1-PRO
Subversion 	1.6.5 (r38866)
jQuery: 	1.3.2

python traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6-py2.6.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6-py2.6.egg/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/api/view.py", line 155, in process_request
    return self._call_filters_and_handler(req, handler)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/api/view.py", line 143, in _call_filters_and_handler
    data = handler(req) or {}
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/scrum/backlog/web_ui.py", line 812, in do_get
    self._do_show(req, data, backlog)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/scrum/backlog/web_ui.py", line 474, in _do_show
    chart_widgets = self._load_chart_widgets(req, backlog)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/scrum/backlog/web_ui.py", line 387, in _load_chart_widgets
    filter_by=filter_by)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/charts/chart_generator.py", line 135, in get_chartwidget
    new_widget  = self._get_widget(name, kwargs, use_cache)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/charts/chart_generator.py", line 110, in _get_widget
    new_widget = generator.generate_widget(name, **kwargs)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/scrum/sprint/charts/resource_assignment_piechart.py", line 42, in generate_widget
    resource_widget.populate_with_sprint_data(sprint_name)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/scrum/sprint/charts/resource_assignment_piechart.py", line 70, in populate_with_sprint_data
    self.data['resource_stats'] = SprintController(self.env).process_command(cmd_resources)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/api/controller.py", line 333, in process_command
    return command.execute(self, date_converter, as_key)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/api/controller.py", line 286, in execute
    return self._execute(controller, date_converter, as_key)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/scrum/sprint/controller.py", line 926, in _execute
    sp_controller)
  File "/usr/local/lib/python2.6/dist-packages/binary_agilo-1.2.1_PRO-py2.6.egg/agilo/scrum/sprint/controller.py", line 881, in get_load_series_for_interval
    self._add_capacity_information(env, sprint.team.name,
AttributeError: 'NoneType' object has no attribute 'name'

for the original auto generated report: http://trac.edgewall.org/ticket/9099

Attachments (1)

trac.ini (6.9 KB) - added by agilouser 10 years ago.
Environment dmedina

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by agilouser

  • Priority changed from major to minor

The problem is a sprint without team assigned. The error message is invalid.

If the message indicate the problem, I think it can be correct.

comment:2 Changed 10 years ago by fschwarz

  • Resolution set to fixed
  • Status changed from new to closed

(In [2400]) prevent creation of sprints in the admin panel that don't have a start date set (fixes #1069)

comment:3 Changed 10 years ago by fschwarz

  • Resolution fixed deleted
  • Status changed from closed to reopened

Actually I'm not sure that my commit fixes your specific bug.

comment:4 Changed 10 years ago by agilouser

The problem is a sprint without team asigned. It's visible in the dashboard and the old view of the sprint backlog.

I'll solve the problema setting again the team.

comment:5 Changed 10 years ago by fschwarz

I tried that and was unable to reproduce the issue with these settings. Can you send us the environment? Actually otherwise I don't see any way to fix it.

Changed 10 years ago by agilouser

Environment dmedina

comment:6 Changed 10 years ago by agilouser

I attach our trac.ini configuration. I hope it help

comment:7 Changed 10 years ago by fschwarz

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [2409]) resource load statistics must not break if no team was assigned (fixes #1069)

comment:8 Changed 10 years ago by fschwarz

Actually I was able to fix the problem finally - fix will be in the next release.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.15 © 2008-2016 Agilo Software all rights reserved (this page was served in: 0.137000 sec.)